Eclipse

From XennisWiki
Jump to: navigation, search

Eclipse is an integrated development environment (IDE). It contains a base workspace and an extensible plug-in system for customizing the environment. Eclipse is written mostly in Java and its primary use is for developing Java applications, but it may also be used to develop applications in other programming languages through the use of plugins, including: [...], C, C++, [...] PHP [...]. It can also be used to develop packages for the software Mathematica. (Wikipedia)

Download

Auf der offiziellen Seite kannst du dir die verschiedenen Eclipse Packages herunterladen. Eine Übersicht über deren Funktionsumfang liefert die Seite Compare Packages.

Weitere Programmiersprachen

Plugins

Einen Großteil der Erweiterungen findest du im Eclipse Martkplace.

Um eine der folgenden Erweiterungen zu installieren Tipp unter Help > Install New Software > Work with die entsprechende Installations-URL ein.

UML

Testabdeckungsmonitor

Software-Metrik

  • Metrics (Installations-URL: http://metrics.sourceforge.net/update)
    • Zu finden unter: Window > Show View > Other > Metrics > Metrics View

Versionskontrollsystem

Apache Subversion (SVN)

Dokumentation

Doxygen

Unit-Test

  • JUnit (Java, standardmäßig in Eclipse enthalten)
  • CUTE (C++)

Tipps & Probleme

JavaDoc

  • Wähle im Package Explorer das Projekt aus
  • Project > Generate Javadoc > unter Javadoc command klickt auf Configure
  • Wähle die Datei javadoc.exe aus, die du im Java Installationsordnern findest (z.B. C:\Program Files\Java\jdk1.7.0_03\bin\javadoc.exe, wobei der Name des Ordners jdk1.7.0_03 abweichen kann, da er von der installierten Java Version abhängt)

Zeichenkodierung

Wenn du mit Eclipse unter Windows arbeitest und dann die erstellten Dateien z.B. unter Linux ausführst, kompilierst, etc, hast du das Problem, dass Sonderzeichen wie z.B. "ä,ö,ü,ß" nicht richtig dargestellt werden. Um dies zu verhindern musst du folgendes in Eclipse einstellen:

  • Windows > Preferences > General > Workspace
  • Feld Text file encoding > Other > UTF-8 auswählen

Tastenkombinationen

Kombination Aktion
[Strg] + [Shift] + [O] Fehlende Klassen importieren
[F3] auf eine Methodennamen Sprung zur Methode
[Strg] + [Shift] + [F] Formatiert den markierten Bereich

Workspace Ordner ändern

Die Einstellungen für die Workspaces kannst du wie folgt vornehmen

  • Window > Preferences > General > Startup and Shutdown > Workspaces

Windows Konsole (cmd) in Eclipse ausführen

siehe How to use cmd prompt inside Eclipse?

Tipp

  • Stelle in den External Tools Configurations > Main
  • Unter Working Directory Variables > die Variable container_loc ein (für das aktuelle Verzeichnis)
  • Unter Arguments
/C BEFEHL

Alternativ

Plugin EasyShell

Integration von FTP und SCP

siehe Eclipse und FTP/SCP

Set dictionary

Install a dictionary (for instance de for German). The installed files are located in /usr/lib/aspell/.

apt-get install aspell-de

Create a dictionary without word compression and store it as de.dict

aspell --lang=de dump master | aspell --lang=de expand | tr ' ' '\n' > de.dict

In Eclipse go to Preferences and search for Spell Checking (under General > Editors > Text Editors). There you can choose the created file as dictionary.

Out of memory problem

Open the eclipse.ini next to the Eclipse binary and adjust the following 4 parameters accordingly

-Xms1024m
-Xmx10200m
-XX:PermSize=256m
-XX:MaxPermSize=256m

See also

External links